List of Open Source Software which can be built on Fugaku

Spack logo
Spack will be used to manage open source software packages on Fugaku. Fugaku users can easily use pre-installed packages and built packages based on Spack recipes. The following list shows the results of building/compiling packages for aarch64 according to the Spack recipes. Note that the results in this list do not guarantee that each package will work properly. On the other hand, Fujitsu will provide the following packages compiled with Fujitsu compiler on Fugaku as "external" packages, of which Spack can be aware.
  • OpenJDK11
  • Ruby 2.6.5 or later
  • Python2 2.7.15
  • Python3 3.6.8
  • Numpy 1.14.3
  • SciPy 1.0.0
  • Eclipse IDE 2019-09 R Packages
Please contact us from email:

Build success rate per compiler


Last Modified: 3/26/20, 10:44 AM GMT
Spack Version: 10/31/19, 11:35 PM GMT
Click each result for further infomation.
Package Version Fujitsu Compiler GCC Clang
abinit 8.10.3 Dependency Error Dependency Error Dependency Error
abyss 2.1.4 Dependency Error Dependency Error Dependency Error
accfft develop Uncategorized Error YES Dependency Error
ace 6.5.6 Download Error Download Error Download Error
ack 2.22 YES YES YES
activeharmony 4.5 Uncategorized Error Uncategorized Error Uncategorized Error
acts-core 0.10.4 Uncategorized Error YES Uncategorized Error
adept-utils 1.0.1 YES YES Dependency Error
adiak 0.1.1 YES YES Dependency Error
adios 1.13.1 YES YES Dependency Error
adios2 2.5.0 Dependency Error YES Dependency Error
adlbx 0.9.2 YES YES Dependency Error
adol-c 2.6.3 YES YES YES
aegean 0.15.2 Dependency Error Out of Condition Dependency Error
aida 3.2.1 Download Error Download Error Download Error
alan 2.1.1 YES YES YES
albany develop Dependency Error Dependency Error Dependency Error
albert 4.0a_opt4 YES YES YES
alglib 3.11.0 YES YES YES
allpaths-lg 52488 Download Error Out of Condition Out of Condition
alquimia xsdk-0.4.0 Spec Error Spec Error Spec Error
alsa-lib 1.1.4.1 Download Error Download Error Download Error
aluminum 0.2.1 Spec Error Spec Error Spec Error
amber 16 Spec Error Spec Error Spec Error
amg 1.2 YES YES Dependency Error
amg2013 master YES YES Dependency Error
aml 0.1.0 YES YES YES
amp develop Uncategorized Error Uncategorized Error Dependency Error
ampliconnoise 1.29 Uncategorized Error YES Dependency Error
amrex 19.10 Uncategorized Error YES Out of Condition
amrvis master Dependency Error Dependency Error Dependency Error
andi 0.10 YES YES YES
angsd 0.921 Uncategorized Error Uncategorized Error Uncategorized Error
ant 1.10.0 Uncategorized Error Uncategorized Error Uncategorized Error
antlr 2.7.7 YES YES YES
ants 2.2.0 Uncategorized Error Uncategorized Error Uncategorized Error
aoflagger 2.10.0 Dependency Error Dependency Error Dependency Error
aom v1.0.0-errata1 YES YES YES
ape 2.2.1 Dependency Error Dependency Error Dependency Error
aperture-photometry 2.7.2 Download Error Download Error Download Error
apex 0.1 Dependency Error Dependency Error Dependency Error
apple-libunwind None Out of Condition Out of Condition Out of Condition
applewmproto 1.4.2 YES YES YES
appres 1.0.4 YES YES YES
apr 1.7.0 YES YES YES
apr-util 1.6.1 YES YES YES
aragorn 1.2.38 YES YES YES
arborx 0.8-beta2 YES YES Dependency Error
archer 1.0.0 Uncategorized Error Uncategorized Error Dependency Error
argobots 1.0rc1 YES YES YES
argp-standalone 1.3 Uncategorized Error Uncategorized Error Uncategorized Error
argtable 2-13 YES YES YES
aria2 1.34.0 YES YES YES
arm-forge 19.0.4-19.0.4-Ubuntu-16.04-x86_64 YES YES Uncategorized Error
armadillo 8.100.1 Dependency Error YES Dependency Error
arpack-ng 3.7.0 YES YES Dependency Error
arrow 0.12.1 Dependency Error Uncategorized Error Dependency Error
asagi 1.0.1 YES YES Dependency Error
ascent develop Spec Error Spec Error Spec Error
asciidoc 8.6.9 YES YES YES
asciidoctor 1.5.8 YES YES YES
aspa master Uncategorized Error YES Dependency Error
aspcud 1.9.4 YES YES YES
aspect 2.0.1 Dependency Error Dependency Error Dependency Error
aspell 0.60.6.1 Uncategorized Error YES Uncategorized Error
aspell6-de 6-de-20030222-1 Dependency Error YES Dependency Error
aspell6-en 2017.01.22-0 Dependency Error YES Dependency Error
aspell6-es 1.11-2 Dependency Error YES Dependency Error
aspera-cli 3.7.7 Download Error Download Error Download Error
assimp 4.0.1 YES YES YES
astra 2016-11-30 YES YES YES
astral 5.6.1 Uncategorized Error Uncategorized Error Uncategorized Error
astyle 3.1 Uncategorized Error Uncategorized Error Uncategorized Error
at-spi2-atk 2.26.2 YES YES YES
at-spi2-core 2.28.0 YES YES YES
athena 4.2 YES YES Dependency Error
atk 2.30.0 YES YES YES
atlas 3.10.3 Dependency Error Dependency Error Dependency Error
atom-dft 4.2.6 Uncategorized Error YES Dependency Error
atompaw 4.0.0.13 Dependency Error Dependency Error Dependency Error
atop 2.2-3 Uncategorized Error Uncategorized Error Uncategorized Error
attr 2.4.47 YES YES YES
augustus 3.3.2 Uncategorized Error YES Uncategorized Error
autoconf 2.69 YES YES YES
autodock-vina 1_1_2 YES YES YES
autofact 3_4 Dependency Error Dependency Error Dependency Error
autogen 5.18.12 YES Dependency Error Dependency Error
automaded 1.0 Dependency Error Uncategorized Error Out of Condition
automake 1.16.1 YES YES YES
awscli 1.16.179 YES YES YES
axel 2.16.1 YES YES YES
axl 0.1.1 YES YES Dependency Error
bamdst master YES YES YES
bamtools 2.5.1 YES YES YES
bamutil 1.0.13 YES YES YES
barrnap 0.8 Dependency Error Dependency Error Dependency Error
bash 5.0 YES YES YES
bash-completion 2.7 YES YES YES
bats 0.4.0 YES YES YES
bazel 0.17.2 Uncategorized Error Uncategorized Error Uncategorized Error
bbcp git Download Error Download Error Download Error
bbmap 38.63 YES YES YES
bc 1.07 YES YES YES
bcftools 1.9 YES YES YES
bcl2fastq2 2.20.0.422 Dependency Error Dependency Error Download Error
bdftopcf 1.0.5 YES YES YES
bdw-gc 8.0.0 YES YES YES
bear 2.2.0 YES YES YES
beast-tracer 1.7.1 Dependency Error Dependency Error Dependency Error
beast1 1.10.4 Dependency Error Dependency Error Dependency Error
beast2 2.5.2 YES YES YES
bedops 2.4.35 YES YES YES
bedtools2 2.27.1 YES YES YES
beforelight 1.0.5 Uncategorized Error Uncategorized Error Uncategorized Error
benchmark 1.5.0 YES YES YES
berkeley-db 6.2.32 YES YES Download Error
bertini 1.5 YES YES Dependency Error
bib2xhtml 3.0-79-ge935 YES YES YES
bigreqsproto 1.1.2 YES YES YES
binutils 2.32 YES YES YES
bioawk 1.0 YES YES YES
biobloom 2.2.0 Uncategorized Error YES Uncategorized Error
biopieces 2016-04-12 Dependency Error Dependency Error Dependency Error
bismark 0.19.0 YES Dependency Error Dependency Error
bison 3.4.2 YES YES YES
bitmap 1.0.8 YES YES YES
blasr 5.3.1 Dependency Error Dependency Error Dependency Error
blasr-libcpp 5.3.1 Dependency Error Dependency Error Dependency Error
blast-legacy 2.2.26 Download Error Download Error Download Error
blast-plus 2.9.0 YES Uncategorized Error YES
blast2go 5.2.5 Uncategorized Error Dependency Error Uncategorized Error
blat 35 Uncategorized Error YES Uncategorized Error
blaze 3.5 Uncategorized Error Uncategorized Error Uncategorized Error
blis 0.6.0 Uncategorized Error Uncategorized Error Uncategorized Error
bliss 0.73 Uncategorized Error YES Uncategorized Error
blitz 1.0.1 Uncategorized Error Uncategorized Error Uncategorized Error
bmake 20180512 Uncategorized Error Uncategorized Error Uncategorized Error
bmi develop YES YES YES
bml 1.3.1 Uncategorized Error YES Dependency Error
bohrium 0.9.1 Spec Error Spec Error Spec Error
bolt 1.0rc2 Uncategorized Error Uncategorized Error Uncategorized Error
bookleaf-cpp 2.0.2 Dependency Error YES Dependency Error
boost 1.70.0 YES YES YES
boostmplcartesianproduct 20161205 YES YES YES
bowtie 1.2.3 YES YES YES
bowtie2 2.3.5.1 YES Uncategorized Error Uncategorized Error
boxlib 16.12.2 Uncategorized Error Uncategorized Error Dependency Error
bpp-core 2.2.0 YES YES YES
bpp-phyl 2.2.0 YES YES YES
bpp-seq 2.2.0 YES YES YES
bpp-suite 2.2.0 Uncategorized Error Uncategorized Error Uncategorized Error
bracken 1.0.0 YES YES YES
braker 2.1.4 Dependency Error Dependency Error Dependency Error
branson 0.82 YES YES Dependency Error
breakdancer master Uncategorized Error YES Uncategorized Error
breseq 0.33.2 YES YES Dependency Error
bridger 2014-12-01 Uncategorized Error Uncategorized Error Uncategorized Error
brigand 1.3.0 Uncategorized Error Uncategorized Error Uncategorized Error
brotli 1.0.7 YES YES YES
bsseeker2 2.1.8 YES YES YES
bucky 1.4.4 YES YES Out of Condition
bumpversion 0.5.3 YES YES YES
busco 3.0.1 Dependency Error Dependency Error Dependency Error
butter 0.3.3 YES YES YES
butterflypack 1.0.3 Dependency Error YES Dependency Error
bwa 0.7.17 Uncategorized Error Uncategorized Error Uncategorized Error
bwtool 1.0 Dependency Error Dependency Error Dependency Error
byobu 5.127 YES YES YES
bzip2 1.0.8 YES YES YES
c-ares 1.13.0 YES YES YES
c-blosc 1.17.0 YES YES YES
c-blosc2 develop YES YES YES
c-lime 2-3-9 YES YES YES
cabana 0.1.0-rc0 YES YES YES
caffe 1.0 Spec Error Spec Error Spec Error
cairo 1.16.0 YES YES YES
cairomm 1.6.4 YES YES YES
caliper 2.0.1 Dependency Error Uncategorized Error Dependency Error
callpath 1.0.4 Dependency Error YES Out of Condition
camellia master Dependency Error Dependency Error Dependency Error
camx 6.50 Uncategorized Error Uncategorized Error Dependency Error
candle-benchmarks 0.1 Spec Error Spec Error Spec Error
cantera 2.4.0 Uncategorized Error Uncategorized Error Dependency Error
canu 1.8 Uncategorized Error Uncategorized Error Uncategorized Error
cap3 2015-02-11 YES YES YES
capstone 4.0.1 YES YES YES
cardioid elecfem Uncategorized Error Uncategorized Error Dependency Error
casacore 2.4.1 Dependency Error Dependency Error Dependency Error
cask 0.8.1 YES YES YES
casper 0.8.2 Uncategorized Error Uncategorized Error Uncategorized Error
catalyst 5.6.0 YES YES Dependency Error
catch2 2.9.1 YES YES YES
cbench 1.3.0 Uncategorized Error YES Out of Condition
cblas 2015-06-06 YES YES Dependency Error
cbtf 1.9.3 Uncategorized Error Uncategorized Error Uncategorized Error
cbtf-argonavis 1.9.3 Dependency Error Dependency Error Out of Condition
cbtf-argonavis-gui 1.3.0.0 Spec Error Spec Error Spec Error
cbtf-krell 1.9.3 Dependency Error Dependency Error Out of Condition
cbtf-lanl 1.9.3 Dependency Error Dependency Error Out of Condition
ccache 3.3.4 YES YES YES

Page 1 of 18, showing 200 record(s) out of 3,574 total